Pop!_OS 20.04 LTS leider nicht geil

Ich bin vor einiger Zeit zu Pop!_OS 20.04 LTS gewechselt, da mir vor allem die Farben und das Design der GUI gefallen hat. Ebenso das einige Pakete schon installiert waren, die mir Arbeit abgenommen haben (z. B. Druckertreiber). Allerdings hatte ich schon zweimal ernsthafte Probleme mit der Version. 

Pop!_OS ist eine Distribution von System76 die Notebooks vertreiben, die sie mit Linux ausliefern, genauso wie Tuxedo aus Deutschland. Beide verwenden die Geräte von Schenker, womit sie sich mehr oder weniger nicht unterscheiden.
Pop!_OS baut auf Ubuntu auf, in diesem Fall auf die Ubuntu Version 20.04 mit dem LTS (Long Term Support), was dafür steht, das bei dieser Version lange supported wird und man legt Wert auf hohe Stabilität. Alle zwei Jahre kommt die LTS Version auf den Markt und wird 5 Jahre supported.
Das Gute an Pop!_OS is, es kommen oft Updates, das schlecht ist, sie werden wohl schlecht getestet oder vermutlich nur auf den Geräten von System76 (und ein paar andere). Ich weiß es nicht genau, aber ausreichend definitiv nicht, sonst hätte ich nicht so Probleme mit den Grafikkarten Treiber gehabt. Mein aktueller Fall war, dass sich erst die von Pop!_OS ausgelieferten nvidia-Treiber nicht installieren haben lassen, kaum konnte ich sie installieren, ging nur noch der IntelChip vom Intel i7 Prozessor. Auf github habe ich gelesen, dass man sudo apt full-upgrade ausführen soll, das führte aber leider zu keiner Verbesserung. Ich habe dann die Treiber deinstalliert und per Hand installiert, gleiches Problem. An sich wäre das nicht so schlimm gewesen, nur leider schafft er der Intel-Chip nicht über die Seagate Firecuda Gaming Dock, die beiden Bildschirme, die ich angeschlossen habe, anzusteuern.

Da das nun nicht das erste Mal war, habe ich nun Pop!_OS von der Festplatte gelöscht und mir das aktuelle Ubuntu 21.04 installiert. Lustigerweise läuft es gefühlt wesentlich flinker, das Notebook ist leise. Ein Problem konnte ich aber schon als Ubuntu Problem identifizieren, das auch unter Pop!_OS auftaucht. Wenn ich einfach nur den Deckel des Notebooks schließe, geht es zwar in den Ruhemodus, mache ich den Deckel aber wieder auf und melde mich an, dauert es nicht lange, bis sich das Gerät wieder sperrt und das passiert dann in einer Dauerschleife. Entweder man schafft es, sich anzumelden und dem Gerät den Shutdown bzw. Reboot zu verpassen, oder aber man muss den Stromschalter solange drücken, bis sich das Notebook abdreht. Ich habe noch nicht nachgesehen, ob sich das Problem fixen lässt, aber das ist mir schon länger im Dorn im Auge. Ich dachte ursprünglich, dass es sich um ein Pop!_OS Problem handelt oder eines der Version 20.04. Bei 21.04 ist das Problem aber leider immer noch vorhanden (dazwischen gab es noch 20.10). Das wäre irgendwie ein Grund, um Windows auf dem Razer Blade 15 2020 zu installieren. Wenn Windows nur nicht so sehr wie Windows wäre ;)

Ich würde wieder zu Pop!_OS zurückkehren, wenn die Distribution stabiler werden würde und das Team um die Distribution einfach besser aufpassen würde, was sie da Deployen. Da ich das Gerät auch teils im Job einsetze, erwarte ich mir ein Stabiles OS und nicht eine Bastler-Distribution.